Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: DidierGreffon GIMP Darktable
#1
Bonjour

J'ai un double boot Windows et Debian
J'utilse Darktable sur la Debian en version 2.4.2 prise sur les depot backports

J'ai recement vu que la version de GIMP 2.10 était sortie et permettait (depuis la 2.9 en fait) de jongler entre GIMP et Darktable.

Edition/preferences/importation exporttation d'images/greffon

N'ayant pas accès à ces version de GIMP je me suis rabattu sur un installation flatpak mais je n'arrive pas ouvrir des RAW dans gimp. un message me dit qu'il faut installer Darktable oub Rawtherapee pour que ce soit possible. C'est pourtant installé !

J'ai donc installé les version windows et testé:  Exactement le même comportement.

Dans la liste Importateur d'Image Raw , j'ai uniquement ${gimp_plug_in_dir}/plug-ins/file-raw-placeholder

Je pense que je devrais trouver un file-darktable et un file-rawtherapee.....

J'ai loupé quelque chose durant l'installation ?



A votre bon coeur.... Wink
Répondre
#2
Je n'ai pas de réponse mais j'ai le même pb (Ubuntu 18.04)
Répondre
#3
Bonsoir, chez moi ça fonctionne avec Ubuntu 18.04 la ligne "${gimp_plug_in_dir}/plug-ins/file-darktable" est bien présente dans les préférences d'importation de Gimp 2.10
Répondre
#4
Je viens d'essayer avec la version Gimp 2.10 Rc1 AppImage sous Linux Mint 18.3 : https://github.com/aferrero2707/gimp-app...4.AppImage
et darktable 2.4.3.
Répondre
#5
(06-05-18, 18:21)Claude Sitt a écrit : Je n'ai pas de réponse mais j'ai le même pb (Ubuntu 18.04)

Bonjour et merci de cette reponse.

"Le même problème" signifie une istallation FLatPak ou bien tu es passé par les dépots ?
Répondre
#6
Oups, j'ai mal lu, j'ai installé Gimp via les dépôts et non en flatpak.
Répondre
#7
(07-05-18, 08:27)Thierry67 a écrit : Oups, j'ai mal lu, j'ai installé Gimp via les dépôts et non en flatpak.

Oui mais en faisant une installetion sur Windows, avec les executables donc...j'ai le même comportement
Répondre
#8
Bonsoir la communauté...

Idem pour moi darktable persiste à lancer la version 2.9.9... comment faire avec lua pour la prise en compte de la 2.10!?

merci de vos possible lumière... Idea 

Michel
LinuxMint Mate 18.4 - darktable 2.4.4
Répondre
#9
La question ici, c'est de lancé darktable avec Gimp 2.10. Pour lancer Gimp 2.10 à partir de darktable, je pense qu'il faut modifier le script Lua.
Répondre
#10
Cela me semble évidant... en regardant le script Lua pour Gimp je trouve ceci :

local gimp_executable = df.check_if_bin_exists("gimp")

et :

local gimpStartCommand
 gimpStartCommand = gimp_executable .. " " .. img_list

 dt.print_log(gimpStartCommand)

 dt.control.execute( gimpStartCommand)

Et enfin :

local executables = {"gimp"}

if dt.configuration.running_os ~= "linux" then
 gimp_widget = df.executable_path_widget(executables)
end

dt.register_storage("module_gimp", _("Edit with GIMP"), show_status, gimp_edit, nil, nil, gimp_widget)

Ça reste de l’Hébreu... Huh
LinuxMint Mate 18.4 - darktable 2.4.4
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)