Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] Comment accelérer Darktable sous Ubuntu?
#1
Bonjour,

C'est vexant : mon DT sous Ubuntu 16.04 est beaucoup moins rapide que mon DT sous Windows 7 !
Comment faire pour changer cela ?

Les conditions du test :
 Je change la température couleur d'une image de mon 5D en cliquant au hasard sur la ligne du curseur.
  • Sous Ubuntu 16.04.4 LTS avec DT 2.4.1 il faut en gros 3 secondes pour que la couleur change.
  • Sous Windows 7 avec DT 2.4 il faut 1 seconde
  • (et sous LR CC2018 la température couleur change encore plus vite, peut-être 0.5 ou 0.3 seconde).
Ma modeste machine :
MSI CR62-6ML
Intel Celeron® CPU 3855U @ 1.60GHz × 2
Intel HD Graphics 510 (Skylake GT1)
12 Go RAM


Est-ce que ce serait lié à OpenCL ?
Pour une raison que je ne comprends pas DT me dit que OpenCL n'est pas disponible sous Ubuntu j'ai pourtant installé Beignet et suivit la procédure expliquée ici
Le résultat du test est : GOOD comme on voit ci-dessous.
[/url]
Code :
ngux:~/Downloads/tools-master/ $ ./print-devices
platform 0: vendor 'Intel'
 device 0: 'Intel(R) HD Graphics Skylake ULT GT1'
ngux:~/Downloads/tools-master/ $ ./cl-demo 1000 10
Choose platform:
[0] Intel
Enter choice: 0
Choose device:
[0] Intel(R) HD Graphics Skylake ULT GT1
Enter choice: 0
---------------------------------------------------------------------
NAME: Intel(R) HD Graphics Skylake ULT GT1
VENDOR: Intel
PROFILE: FULL_PROFILE
VERSION: OpenCL 1.2 beignet 1.1.1
EXTENSIONS: cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_fp16 cl_khr_spir cl_khr_icd
DRIVER_VERSION: 1.1.1

Type: GPU
EXECUTION_CAPABILITIES: Kernel Native
GLOBAL_MEM_CACHE_TYPE: Read-Write (2)
CL_DEVICE_LOCAL_MEM_TYPE: Global (2)
SINGLE_FP_CONFIG: 0x6
QUEUE_PROPERTIES: 0x2

VENDOR_ID: 32902
MAX_COMPUTE_UNITS: 12
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_GROUP_SIZE: 512
PREFERRED_VECTOR_WIDTH_CHAR: 16
PREFERRED_VECTOR_WIDTH_SHORT: 8
PREFERRED_VECTOR_WIDTH_INT: 4
PREFERRED_VECTOR_WIDTH_LONG: 2
PREFERRED_VECTOR_WIDTH_FLOAT: 4
PREFERRED_VECTOR_WIDTH_DOUBLE: 0
MAX_CLOCK_FREQUENCY: 1000
ADDRESS_BITS: 32
MAX_MEM_ALLOC_SIZE: 1073741824
IMAGE_SUPPORT: 1
MAX_READ_IMAGE_ARGS: 128
MAX_WRITE_IMAGE_ARGS: 8
IMAGE2D_MAX_WIDTH: 8192
IMAGE2D_MAX_HEIGHT: 8192
IMAGE3D_MAX_WIDTH: 8192
IMAGE3D_MAX_HEIGHT: 8192
IMAGE3D_MAX_DEPTH: 2048
MAX_SAMPLERS: 16
MAX_PARAMETER_SIZE: 1024
MEM_BASE_ADDR_ALIGN: 1024
MIN_DATA_TYPE_ALIGN_SIZE: 128
GLOBAL_MEM_CACHELINE_SIZE: 64
GLOBAL_MEM_CACHE_SIZE: 8192
GLOBAL_MEM_SIZE: 2147483648
MAX_CONSTANT_BUFFER_SIZE: 134217728
MAX_CONSTANT_ARGS: 8
LOCAL_MEM_SIZE: 65536
ERROR_CORRECTION_SUPPORT: 0
PROFILING_TIMER_RESOLUTION: 80
ENDIAN_LITTLE: 1
AVAILABLE: 1
COMPILER_AVAILABLE: 1
MAX_WORK_GROUP_SIZES: 512 512 512
---------------------------------------------------------------------
*** Kernel compilation resulted in non-empty log message.
*** Set environment variable CL_HELPER_PRINT_COMPILER_OUTPUT=1 to see more.
*** NOTE: this may include compiler warnings and other important messages
***   about your code.
*** Set CL_HELPER_NO_COMPILER_OUTPUT_NAG=1 to disable this message.
0.000114 s
0.105592 GB/s
GOOD
[url=https://askubuntu.com/questions/850281/opencl-on-ubuntu-16-04-intel-sandy-bridge-cpu]
Photographe pro qui tente de passer tout son workflow sous Linux.
Répondre
#2
Pour l'instant, la prise en charge de l'OpenCl des cartes Intel n'est pas optimal sous Linux. Les cartes NVidia sont très bien gérées avec le driver de NVidia pour Linux, pour les cartes Radeon supportées pas le AMDGPU-PRO.
Ta carte Intel est prise en charge dans darktable ?
Je n'ai pas vraiment d'explication pour la lenteur sous Ubuntu, as-tu exactement les mêmes configurations sur les 2 systèmes ?
Répondre
#3
Je ne sais pas si c'est encore le cas, mais beignet était blacklisté de darktable à une époque :

http://darktable-devel.narkive.com/jGgAb...on-beignet

C'est fort possible que dt refuse d'utiliser ta carte graphique à cause de ça sous Linux, et qu'il accepte sous Windows parce que le driver est différent.

Que donne darktable-cltest (sur les 2 OS) ?
Répondre
#4
Tu devrais supprimer Beignet qui n'est pas supporté par darktable et rend généralement le traitement plus lent!
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#5
Big Grin 
(12-04-18, 08:50)jpg54 a écrit : 1/ Ta carte Intel est prise en charge dans darktable ?
2 / Je n'ai pas vraiment d'explication pour la lenteur sous Ubuntu, as-tu exactement les mêmes configurations sur les 2 systèmes ?

réponse à 1/ OpenCL n'est pas prise en charge si c'est ce que tu veux dire. Sinon je veux bien une explication pour expliquer ce que tu appelles "carte prise en charge dans DT"

réponse à 2/ Bien vu ! tu avais raison, je n'avais pas la même config. Dans Windows 7 j'avais dans "méthode de dématricage pour la vue en chambre noire = toujours bilinéaire
alors que dans Ubuntu j'avais choisi = au mieux PPG

 C'est ce réglage qui ralentissait vraiment fort les opérations de la chambre noire. Une fois remis sur "toujours bilinéaire" dans DT sur Ubuntu, je suis même un tout petit peu plus rapide sur Linux  Big Grin   que sur Windows 7 même sans OpenCL. C'est vraiment sensible.
Et pour dire vrai je ne vois pas la différence sur la qualité de l'image.
Je passe donc le sujet en [résolu]

(12-04-18, 16:47)pascal a écrit : Tu devrais supprimer Beignet qui n'est pas supporté par darktable et rend généralement le traitement plus lent!

Je vais faire comme tu suggères. Merci

(12-04-18, 08:54)mmoy a écrit : Que donne darktable-cltest (sur les 2 OS) ?

Voici le test sur Ubuntu, je n'ai pas réussi à le faire sur Windows 7, j'ai mis la commande dans cmd.exe mais elle n'a pas fonctionné. Comment fallait-il faire pour Windows ?
Code :
ngux:~/ $ darktable-cltest
[opencl_init] opencl related configuration options:
[opencl_init]
[opencl_init] opencl: 1
[opencl_init] opencl_library: ''
[opencl_init] opencl_memory_requirement: 768
[opencl_init] opencl_memory_headroom: 300
[opencl_init] opencl_device_priority: '*/!0,*/*/*'
[opencl_init] opencl_mandatory_timeout: 200
[opencl_init] opencl_size_roundup: 16
[opencl_init] opencl_async_pixelpipe: 0
[opencl_init] opencl_synch_cache: 0
[opencl_init] opencl_number_event_handles: 25
[opencl_init] opencl_micro_nap: 1000
[opencl_init] opencl_use_pinned_memory: 0
[opencl_init] opencl_use_cpu_devices: 0
[opencl_init] opencl_avoid_atomics: 0
[opencl_init]
[opencl_init] found opencl runtime library 'libOpenCL'
[opencl_init] opencl library 'libOpenCL' found on your system and loaded
[opencl_init] found 1 platform
[opencl_init] found 1 device
[opencl_init] discarding device 0 `Intel(R) HD Graphics Skylake ULT GT1' because the driver `OpenCL 1.2 beignet 1.1.1' is blacklisted.
[opencl_init] no suitable devices found.
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.
Photographe pro qui tente de passer tout son workflow sous Linux.
Répondre
#6
j'ai eu ce probleme de lenteur et j'ai lu un sujet sur le swap qui se déclenche avec 60% de ram utilisée. une commande permet de declencher lorsque la mémoire est prise à 95%
https://doc.ubuntu-fr.org/swap

et donc lancer les commandes...

echo vm.swappiness=5 | sudo tee /etc/sysctl.d/99-swappiness.conf
echo vm.vfs_cache_pressure=50 | sudo tee -a /etc/sysctl.d/99-swappiness.conf
sudo sysctl -p /etc/sysctl.d/99-swappiness.conf


j'ai enormément gagné en vitesse rien qu'avec ces quelques lignes.
hp compaq  - 4 go ram ssd 275 GO
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
linux mint 18 sarah

Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)