Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: RaghnarokErreur données EXIF
#1
Hello,

Je sais pas vraiment si c'est le bon endroit pour ce problème, mais bon.

J'ai mon darktable qui confond mon objectif Sigma 20mm f/1.4 DG HSM avec un Canon EF 24 f/1.4L II.
J'ai compris que cela venait du paquet exiv2. J'ai pu le mettre à jour à la version 0.26 et maintenant, à l'exécution de la commande suivante, j'ai le bon résultat:

Code :
$exiv2 -pt IMG_5039.CR2 | grep -ai lens
Exif.CanonCs.LensType                        Short       1  Sigma 20mm f/1.4 DG HSM | A
Exif.CanonCs.Lens                            Short       3  20.0 mm
Exif.Canon.LensModel                         Ascii      70  20mm F1.4 DG HSM | Art 015

En revanche, sur darktable il me reconnaît toujours le Canon.

Quelqu'un a une idée d'où vient le problème?
Répondre
#2
As-tu regardé les exif qu'affiche darktable ? Peux-tu mettre une copie d'écran ?
Répondre
#3
(11-03-18, 13:43)jpg54 a écrit : As-tu regardé les exif qu'affiche darktable ? Peux-tu mettre une copie d'écran ?

[Image: Capture_d_cran_2018_03_11_13_54_00.png]

J'ai pas trouvé d'autre endroit où visualiser les exif sur darktable, du coup j'imagine qu'il y a que sur la table lumineuse.

P.S.: Je me demande si ce n'est pas lié au fait qu'il semble ne pas y avoir le Sigma 20mm f/1.4, du moins je ne le vois pas dans la liste du module de correction d'objectif...
Répondre
#4
Tu as la réponse, darktable voit à travers de LensFun un Canon Ef 24 f:1.4L II.
Répondre
#5
@jpg54, non ça c'est la vue exif de la libexiv2. Les données lensfun sont uniquement dans le module "correction des objectifs".
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#6
(11-03-18, 18:27)pascal a écrit : @jpg54, non ça c'est la vue exif de la libexiv2. Les données lensfun sont uniquement dans le module "correction des objectifs".

Du coup il y a un soucis quelque part...

Par contre après une petite recherche j'ai pu valider le fait que lensfun n'a pas encore le support de mon Sigma, il est dans la version en dev donc ça tardera pas.

Mais si c'est les données exiv2, d'où peut venir la différence?
Répondre
#7
(11-03-18, 19:05)Raghnarok a écrit : Mais si c'est les données exiv2, d'où peut venir la différence?

Ca, je n'ai pas d'explications mais en tous les cas, la correction d'objectifs prend comme valeurs celles dans la visualisation des exif dans darktable.
Répondre
#8
Je me suis peut être mal exprimé. Les données exif (dialogue affiché plus haut) sont utilisées par le module "correction des objectifs" pour trouver le boiter et l'objectif dans la base de données de lensfun.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#9
(11-03-18, 19:26)pascal a écrit : Je me suis peut être mal exprimé. Les données exif (dialogue affiché plus haut) sont utilisées par le module "correction des objectifs" pour trouver le boiter et l'objectif dans la base de données de lensfun.

D'accord, mais alors d'où viennent les exifs de la table lumineuse? De exiv2? Si oui comment cela se fait-il que ça ne soit pas le même que si je demande à exiv2 directement?
Répondre
#10
Parce que ton darktable a été compilé avec une version antérieure à la 0.26 que tu as ajouté à ton système. il utilise donc cette version antérieure.

Pour voir les différentes versions disponibles sur ton système :

Code :
find /usr -iname libexiv2\* -ls
 ce qui donne sur ma machine :

Code :
$ find /usr -iname libexiv2\* -ls
101026632    0 lrwxrwxrwx   1 root     root           18 nov.  9 12:44 ./lib64/libexiv2.so.14 -> libexiv2.so.14.0.0
101026633 3060 -rwxr-xr-x   1 root     root      3131240 oct. 17 16:25 ./lib64/libexiv2.so.14.0.0
102774990    0 lrwxrwxrwx   1 root     root           18 déc.  3 22:06 ./lib64/libexiv2.so.26 -> libexiv2.so.26.0.0
101925079 3236 -rwxr-xr-x   1 root     root      3311632 déc.  2 19:20 ./lib64/libexiv2.so.26.0.0
 J'ai donc deux versions installées : la 14 et la 26

Pour savoir quelle version DT utilise :

1) récupérer le pid de darktable avec ps.

Code :
ps -u | grep darktable

2) lister tous les fichiers ouverts par darktable et filtrer sur exiv2

Code :
lsof -p <Le PID> | grep exiv2

ce qui donne chez moi :

Code :
darktable 8673  jpv  mem       REG                8,2   3131240  101026633 /usr/lib64/libexiv2.so.14.0.0
Donc, dans ma distrib, darktable utilise la version 14, bien que la 26 soit installée

Pour corriger cela, une seule solution, compiler toi même darktable, ce qui permettra d'utiliser la bonne librairie.
Mes photos : jpverrue.fr
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)