Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Darktable 2.4 et lua
#1
Bonsoir,


J'ai installé darktable 2.4. Je suis nouvelle utilisatrice de darktable. J'en profite pour remercier la communauté pour tout ce travail !
(et en particulier,les vidéos de Carafife, une mine d'or !).
N’empêche que je bloque !
Je suis sur pc portable pas tout jeune et Ubuntu 17.10.

Lorsque je vérifie mon installation j'obtiens :
Code :
pepette@pepette-N61Jq:~$ darktable  --version
this is darktable 2.4.0~rc0
copyright (c) 2009-2017 johannes hanika
darktable-dev@lists.darktable.org

compile options:
 bit depth is 64 bit
 normal build
 SSE2 optimized codepath enabled
 OpenMP support enabled
 OpenCL support enabled
 Lua support disabled
 Colord support enabled
 gPhoto2 support enabled
 GraphicsMagick support enabled
 OpenEXR support enabled

Code :
pepette@pepette-N61Jq:~$ locate liblua5.3
/usr/lib/x86_64-linux-gnu/liblua5.3-c++.so.0
/usr/lib/x86_64-linux-gnu/liblua5.3-c++.so.0.0.0
/usr/lib/x86_64-linux-gnu/liblua5.3.so.0
/usr/lib/x86_64-linux-gnu/liblua5.3.so.0.0.0
/usr/share/doc/liblua5.3-0
/usr/share/doc/liblua5.3-0/changelog.Debian.gz
/usr/share/doc/liblua5.3-0/copyright
/var/lib/dpkg/info/liblua5.3-0:amd64.list
/var/lib/dpkg/info/liblua5.3-0:amd64.md5sums
/var/lib/dpkg/info/liblua5.3-0:amd64.shlibs
/var/lib/dpkg/info/liblua5.3-0:amd64.triggers

Alors, je ne comprends pas bien pourquoi le support de lua n'est pas actif.

Le fameux print("Hello World !") dans le fichier ~/config/darktable/luarc n'affiche donc rien dans la console.

Une piste ?

Merci
Répondre
#2
Je n'ai jamais su faire fonctionner Lua avec une version compilée depuis les sources GitHub. Il va falloir attendre que la version soit paquetée en .deb.
Répondre
#3
Tu dois installer le paquet dev de Lua. Ton locate ne montre que les bibliothèques dynamiques. Lors de la compilation il te faut les fichiers C headers et la bibliothèque pour le link.

Sous Debian:


Code :
$ sudo apt install liblua5.3-dev

Donc je suppose que la version compilée a été faite sans ce paquet de dev. Tu devrais remonter cela au mainteneur de darktable sur ta distrib.

Ma réponse est un mixte de réponse pour les deux messages précédents.

Bon pour être plus claire quant à la question de pepette:

Code :
Lua support disabled

Donc la version que tu as installée n'a pas le support Lua. Cela ne vient pas de chez toi mais du choix (ou non) de compilation par le mainteneur. Donc remonte le problème au mainteneur qui se fera un plaisir de compiler dt avec le support Lua.
--
Pascal - GNU/Debian (sid) - version darktable git/master
Répondre
#4
Merci pour ta réponse Pascal. Je sais pas comment pepette a installé darktable 2.4 sous Ubuntu 17.10, pour l'instant je n'ai pas vu de paquet pour cette version ?

Pascal, j'ai bien liblua5.3-dev installé sur ma machine.
Répondre
#5
Et /darktable --version/ dit quoi? Reporte-il que Lua est activé?
--
Pascal - GNU/Debian (sid) - version darktable git/master
Répondre
#6
Voilà Pascal :
Code :
jpg@jpg-HP-ProBook-4535s /opt/darktable/bin $ ./darktable --version
this is darktable 2.4.0rc0+27~g18a2f40
copyright (c) 2009-2017 johannes hanika
darktable-dev@lists.darktable.org

compile options:
 bit depth is 64 bit
 normal build
 SSE2 optimized codepath enabled
 OpenMP support enabled
 OpenCL support enabled
 Lua support enabled, API version 5.0.0
 Colord support enabled
 gPhoto2 support enabled
 GraphicsMagick support enabled
 OpenEXR support enabled
Répondre
#7
Et bien ton Lua est activé. Alors normalement ça doit fonctionner.
--
Pascal - GNU/Debian (sid) - version darktable git/master
Répondre
#8
Salut à vous,

Merci pour vos réponses !

Pascal, j'ai installé  liblua5.3-dev et recompilé darktable et tout est marche nickel ! 

Voilà en résumé ce que j'ai fait :
Code :
sudo apt install liblua5.3-dev
./build.sh --prefix /opt/darktable --build-type Release
sudo  cmake --build "/home/pepette/Téléchargements/darktable-2.4.0~rc0/build" --target install -- -j8



jp54, j'ai récupéré les sources ici et suivi les instructions "easy way" de la doc. Attention, j'ai eu pas mal de librairies à installer, ce n'est pas passé du premier coup.


Encore merci à vous !!

Armelle
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 5 visiteur(s)