Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
OpenCL installation AMDGPU
#1
Depuis la mise à jour d'Ubuntu de la version 14.04 vers la 16.04 il y a peu de temps, il semble que j'ai des problèmes pour utiliser OpenCL via Darktable (version 2.2.3). J'ai remarqué cela principalement, car la charge de mon processeur a augmenté considérablement lorsque j'utilise Darktable tout en étant sensiblement plus lent.

Je suis inscrit sur la liste de diffusion des utilisateurs de Darktable : darktable-user@lists.darktable.org il y a actuellement une activité notable autour de problème OpenCL et des cartes graphiques AMD. Je dois bien avouer ne pas avoir tout lu en grande partie parce que mes connaissances concernant l'utilisation du GPU sont particulièrement médiocres.  [Image: sad.png]  
J'ai essayé d'installer via le site d'AMD les pilotes AMDGPU-Pro. Je ne suis pas sûr de l'avoir fait correctement, mais en tout cas je n'ai noté aucune amélioration des performances de Darktable.  Pour fixer les choses, je pense qu'il est nécessaire de partager mes infos concernant ma carte graphique. Si j'ai à peu près suivi, la commande lspci est de rigueur :

Code :
lspci -v
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
    Flags: bus master, fast devsel, latency 0, IRQ 28
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f7e00000 (64-bit, non-prefetchable) [size=256K]
    I/O ports at e000 [size=256]
    Expansion ROM at f7e40000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: amdgpu
    Kernel modules: radeon, amdgpu

J'espère que la communauté Darktable pourra m'aider. Je trouve Darktable génial et son utilisation m'a convaincu à 200% et je ne veux surtout pas changer [Image: smile.png] 

Au passage, j'aimerais bien trouver un programme permettant de suivre la charge d'utilisation du GPU ! Pour le CPU et la RAM j'utilise laod-indicator (https://launchpad.net/indicator-multiload) qui me convient très bien et j'aimerais bien trouvé un équivalent pour le GPU ou une app qui fait tout en même temps  [Image: biggrin.png] . 

Merci
Répondre
#2
Réponse simple et pas sympa pour toi mais ta carte RX 280 n'est pas supporté par AMDGPU-PRO.

Je suis le gars sur la liste qui c'est presque fait insulté pour avoir dit de ne surtout pas acheter de carte AMD et préférer NVIDIA. Pourquoi?

Comme tu as pu t'en rendre compte AMD ne supporte plus fglrx et tu dois donc utiliser AMDGPU et même AMDGPU-PRO pour l'OpenCL. Le problème est que beaucoup d'anciennes cartes GPU ne sont plus supporté par AMDGPU-PRO. La solution rester en Ubuntu 14.04!

Avec NVidia la situation est meilleure, le driver proprio (car comme AMD il n'y a que le driver proprio qui support les GPU) vient avec les nouvelles versions sous forme de module dkms et suivent bien les nouveaux noyaux linux. Et pour le moment (et depuis longtemps) NVidia n'a pas supprimé le support pour les anciens GPU.

J'ai eu ce problème très récemment et j'ai tout simplement changé de portable et j'ai choisi une carte NVidia.
Répondre
#3
Bonjour Pascal,

J'avais vu tes réponses, mais en faite je crois que je n'ai pas voulu vraiment croire ce qu'il y avait dedans !
Je me suis dit qu'il y avait un truc à faire, surtout que pour moi ma carte Graphique est récente je l'ai acheté il y a 2 ans ... Considérer que c'est une vieille carte me fait vraiment mal. Surtout vu le prix que je l'ai payé Sad(((((

J'avais imaginé qu'il y avait une solution et qu'en postant ici cela pourrait aider d'autres personnes dans le même cas.
N'y a-t-il pas un moyen de faire fonctionner OpenCL en utilisant des pilotes Open source, j'étais tombé sur ce lien :
https://help.ubuntu.com/community/RadeonDriver
Il y a un tableau précisant que ma carte graphique est compatible avec les Drivers sous la version 16.04.

Bon je ne suis pas vraiment sur non plus !
Sur le site AMD, je suis arrivé à trouver que les cartes RADEON R9 270X et 290X sont compatibles avec la version 16.60 des drivers, mais je n'y ai pas trouvé la série R9 280X ! 

L'option NVIDIA est impossible puisque je n'ai actuellement pas du tout les moyens de m'acheter une carte graphique ... 

Y a-t-il quand même un moyen de faire marcher la carte en combinant différentes choses ? 
Merci de m'aider
Répondre
#4
> Il y a un tableau précisant que ma carte graphique est compatible avec les Drivers sous la version 16.04.

Oui mais le driver Open Source n'a pas le support "Image" dans l'OpenCL ce qui est nécessaire pour darktable.

Et visiblement la 280X n'est pas supporté par AMDGPU-PRO.

> Y a-t-il quand même un moyen de faire marcher la carte en combinant différentes choses ?

Je ne peux pas dire non, mais j'ai passé des heures sur ce problème sans solution pour ma carte.
Répondre
#5
bonjour,

sur ma version 2.2.5 j'ai plus la possibilité d'utiliser le gpu.

j'ai lancé des commandes

---
$ sudo update-pciids
[sudo] Mot de passe de patrick :
Downloaded daily snapshot dated 2017-07-15 03:15:02
$ lspci -nn | grep -E 'VGA|Display'
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000] [1002:9616]
patrick@patrick-win7:~$

---

et donc chipset video RS780L Qui logiquement est reconnu par ubuntu 16.04 et supérieurs mais apparemment opencl ne s'installe pas sur linux mint. comment je fais pour installer opencl.



---
$ sudo lsb_release
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarchConfusedecurity-9.20160110ubuntu0.2-amd64Confusedecurity-9.20160110ubuntu0.2-noarch
---
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)